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CHAPTER 1

Warning - This manual
This manual is slowly being replaced by individual Reference manuals.
As new manuals are produced the corresponding section(s) will be removed from this manual, so
there may be some interesting "glitches" as the process continues.
We apologize for this but we are working hard to improve the quality of content and the readability
of the manuals and this is an unfortunate by-product of the process.
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CHAPTER 2

Main Menu
The main menu contains several sections which let you control some of the basic functions of the
administration interface.

Field

Description

Open File

Allows you to open any text file with the VisNetic MailServer text editor. Useful
for viewing or editing plain text files.

Save Config

Saves any changes that have been made in the Administration Console.

Reload Config

Reloads the Administration Console. Any changes that have been made (e.g.
via the API or Web Administration console) will be reflected after the reload.
Shortcut F5 can be used.

Connect

Allows you to connect to and administer a Remote VisNetic MailServer
installation. For more information see Remote Server Administration (on
page 6).

Disconnect

Disconnects from a Remote server.

Backup
Configuration

Allows you to backup your current configuration to an .mcb file. This file
contains your entire server and user/domain configuration information. For
more information see Configuration Backup and Restore (on page 9).

Restore
Configuration

Allows you to restore your configuration from an .mcb file.

Exit

Exit the VisNetic MailServer Administration Interface.

Before doing so, we recommend that you rename the config directory. This
will ensure you can revert if your restore is not as you required. For more
information see Configuration Backup and Restore (on page 9).
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Field

Description

Interface mode

You can choose one of three modes for the VisNetic MailServer Console, which
affects the nodes that are visible in the left hand pane.
Advanced Mode
All menu nodes and all options will be shown.
Basic Mode
Some advanced menu nodes and options will be hidden. The options that are
hidden tend to be rarely or should only be used by advanced administrators.
Custom Mode
You can customize the interface, selecting which nodes and options are shown.

Require
Authentication To
Access the System
Configuration

Anyone accessing the Administration Console will be required to enter a valid
User/Password combination.

Use Safe Delete
Confirmation

A confirmation dialog will appear before any deletion is performed.

Show Splash
Screen At Startup

If checked, the Welcome splash screen will be displayed when VisNetic
MailServer Console starts.

Add to systray on
minimize

If checked and you minimize VisNetic MailServer Console, an icon is shown in
your System Tray (the panel to the right of your Windows Taskbar). If not
checked then VisNetic MailServer will be shown in the Taskbar instead.

Automatically
refresh selected
statistics panel

If checked the statistics panel is refreshed every 30 seconds while it is
displayed.

Do Not Check For
New Version on the

By default, VisNetic MailServer checks for a new version each time it starts.
Select this option to stop VisNetic MailServer making this check.
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Internet
Customize
toolbar...

Opens a dialog which allows you to customize the VisNetic MailServer toolbar.

Languages >

The default language for VisNetic MailServer is English, but it can be localized
by use of XML files.

See Toolbar Customization (on page 11).

When alternative XML files exist this option will show the files available.
See Load Language (see "Languages" on page 17).

Field

Description

Add

Allows you to add accounts to VisNetic MailServer. The menu will expand to
show a list of Account types that can be added.

New Domain

Creates a new Domain in VisNetic MailServer.

Make Primary

Makes the currently selected Domain the Primary Domain.
Primary Domains are used to specify the system postmaster and other system
information.
The Primary Domain is always shown first in the list of Domains.

Find

Allows you to search all domains. You can search for User names, Aliases or
Email Addresses. VisNetic MailServer uses basic search criteria with limited
output.
See more details in the Find Dialog (on page 14) section.

Import Accounts
From File/Export

Please see Import / Export Users From / To File (on page 13).
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Accounts To File
Import Windows NT
users

Please see How to Import Users From Windows NT (see "How to Import
Users from Windows NT or AD Servers" on page 12).

User's Mailbox

Opens the Message Queue window showing the Mailbox for the selected User
Account.

User's Spam Folder

Opens the Message Queue window showing the Spam Folder for the selected
User Account.

User's Statistics

Opens the User Statistics window for the selected User Account.

Volume

Opens the Volume window for the selected User or Domain Account.

The Help menu contains common items such as links to Company Web Sites and Release Notes.
The most important are the Help Topics item, which opens Context Sensitive HTML Help and the
Licenses item, which opens the Licenses (on page 15) dialog where you can manage your Licenses.
The "Check For New Version..." option will query the official site to see if there is a newer version of
VisNetic MailServer available.
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Remote Server Administration
Remote Server Administration is available for VisNetic MailServers. The same Administration
Interface is shown as with the local Administration Console but some features are not available,
some to avoid connection problems and some that are technically impossible (e.g. ODBC and
Volume settings).
The connection to your Server is encrypted using a secure cipher and compressed for better
performance.
All you need on your remote machine is the config.exe program and you can access your VisNetic
MailServer.
Running config.exe starts the standard VisNetic MailServer Console. To access a Remote server
simply choose File -> Connect from the menu or press the Connect button on the toolbar (left hand
icon).
You can run multiple instances of config.exe allowing you to compare settings on different servers.
There is a remote configuration tool available on the company website.
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Connection Manager
The Connection Manager allows you to pre-define any connections you require so you can quickly
connect to a server.

The Quick Connect button opens the last used connection.
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Pressing the Add button opens the dialog to add a connection as follows:

Field

Description

Server

The hostname or IP address of the server you wish to connect to.

Administrator

An Administrator Account for the remote server.

Password

The password for the Administrator account.

Port

The port that the Remote Web\Control Service is listening on.

Description

A description for this connection.

Use SSL Connection

If checked, all data transfer will be SSL encoded.

Save password

If checked, your password will be saved so you do not have to enter it each
time you connect.
USE WITH CARE - not recommended on public machines!
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Field

Description

Use proxy server

Check this if you need to access your server via a Proxy Server.

Host

The hostname or IP address of the proxy server.

Port

The port which you need to use to contact the proxy server (depends on your
proxy server setup).

Configuration Backup and
Restore
The VisNetic MailServer configuration data is stored in these folders:
<InstallDirectory>/Config/
<InstallDirectory>/Spam/
<InstallDirectory>/Calendar/
<InstallDirectory>/WebMail/Config/
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and the folders contain the following information:


General server settings



All account and domain settings (user-names, passwords, details etc.) - unless you are using
ODBC storage.



Databases (but only if you are using VisNetic MailServer's default .mdb databases).



AntiSpam Rules



Filters

You can easily backup your configuration by using the menu item File -> Backup Configuration.
You should be aware that you can also automate this process using the Tools - System Backup
option

It is recommended that you perform a backup after your final configuration.
In case of a hardware failure you will be able to restore your configuration.
It is recommended that you backup regularly and the backup file is kept somewhere safe such as
written to a removable media and taken off site.

Configuration Restore
Choosing the Restore option will prompt you for a file containing backed up data. Once a file is
chosen and opened, the configuration will be restored. Use this option carefully in order to prevent
overwriting your active configuration with an older version. You should previously rename the Config
directory so the restore is completely fresh.
Should a server have to be rebuilt and all software freshly installed, this Restore provides an
excellent way of retrieving all the users' account information without retyping.
NOTES
If you restore a backup to a different machine then your Server Reference Key will change and your
license will be invalid. See the licenses (on page 15) section for information on how to retrieve a
new license.
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Also you should be aware that the restore will restore data to the same paths they were backed up
from, so if you have:
Modified your VisNetic MailServer configuration paths (see Storage - Directories)
Changed the installation path for VisNetic MailServer
Installed VisNetic MailServer on a new server with a different hard drive configuration
you may get unexpected results and a failed restore.

Toolbar Customization
You can customize your toolbar within VisNetic MailServer. You can add and remove icons and insert
dividers to streamline your use of the interface.

The dialog can be accessed in two different ways:


Right-click the toolbar and click Customize item in the pop-up menu.



Click Options -> Customize toolbar in the menu.
The items in the left pane are the items you can add to the toolbar:
Items are categorized into Menu items and Functions, selected by choosing one of the options in
the Toolbar source drop-down box.
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To add an item to the toolbar select it in the left pane and click Add.
Items are added to the bottom of the list in the right pane.
The items visible in the right hand pane are (or will be) part of your toolbar:
To remove an item select it in the right pane and click Remove.
To add a divider to the toolbar click Add Divider. The divider bar will be added at the end of the
list.
To re-order items within the toolbar select an item in the right pane and click the up arrow and/or
down arrow until the item is where you want it.
When you are satisfied with your new selection click OK to apply it.
Click Cancel at any time to close the dialog without making any changes.

How to Import Users from
Windows NT or AD Servers
If you have User Accounts already set up in a Windows NT or Active Directory User Database you
can import these into VisNetic MailServer to save you re-typing them manually.
To Import users select Accounts -> Import / Export -> Import Windows NT Users... the following
dialog will be displayed.

A list of discovered Users will be displayed in the left pane.
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Select the Users you wish to Import and press the Add button.
To show a list of Users from different domains/servers enter the details in Server name and press
Load.
When your list of Users is ready press Import to import the Users into VisNetic MailServer.
NOTE
Passwords cannot be retrieved from any Windows system so these will have to be entered manually.
AD users must have AD authorization.
The User authentication mode lets you specify the mode for all imported users. See the user
account authentication mode description in User - Definition.

Import / Export Users From / To
File
The primary use of this function is to export and import user accounts between two VisNetic
MailServers.
For transferring users to another mail server we recommend using the command line TOOL.EXE.
This powerful feature lets you export accounts from the selected domains to a specially formatted
text file (.MAE).
The file includes all Account types and account properties including the Email Address, Account
Name, Account Type (as an integer value), Password and Properties (as an encoded string).
This file can be edited using a standard text editor.
The import feature lets you import accounts from the export file.
There are some important points you should be aware of:

created.

if a domain listed in the file is missing in VisNetic MailServer it will be automatically

if any property values are not available in either the first four or as part of the encoded
string then account defaults will be used.
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It is highly recommended that you experiment with this facility before you use it on any large
number of accounts on a production server.

File Structure
<address>,<properties>

Example
fred@vmsdemo.com,eJxjYGBg4AsuScxLSSxKUQgtTi2yhlAMIwYwspSOKP9igAH3PyOEctj5yGEgrB9w/
w8wEM5NLUrMTknNzddLzs+NAYVGzEC7aWBAAwNDcW6xLigEHGDhMdBuoi9gtB5oF4yCUTAKRsHgAA
DS/h28

Find Dialog
The "Find" dialog can be used to locate Accounts within your VisNetic MailServer.
Select Accounts -> Find and the following dialog will open.

In Alias / Name specify a string you wish to locate in the name of the account.
And/or
In Domains specify a string you wish to locate within the Server name.
Select an Account type if you wish to limit your search to a particular account type.
E.g. In the above screenshot we are looking for User Accounts with the string "user" in the account
name AND the string "vmsdemo.com" in the domain name.
Press the find button and your criteria are used as a filter within the Administration Console display.
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Selecting the Management node now will show a tree which only shows the accounts which comply
with the filter you set.
WARNING - You will need to open the Find dialog again and clear your criteria to see all your
domains and accounts again. However, the criteria are NOT saved when the Console is closed

Licenses
You can check your license information in the Help menu - licenses. The following dialog is opened.

By default, it shows a list of all your registered licenses.
By checking the Display all licenses option you can see the status of licenses for all VisNetic
MailServer modules.
The Product column shows the name of the VisNetic MailServer Module.
The Type column shows the type of license you own for the module (evaluation or registered).
The Accounts column shows the number of accounts that this license is valid for.
The Expires in column shows the number of days this modules license has before it expires.
The Renewal period column shows the number of days left during which you can upgrade this
module.
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The Exceed column shows the number of accounts exceeding the module's licensed accounts. If
this happens, you can enable/disable the service for a particular user in the Service Access
section under the User - Options tab.
The Server reference key is your unique reference generated for the specific machine on which
VisNetic MailServer is running. The key is generated using machine hardware and software
information and as such is not transferable between machines. If you migrate VisNetic MailServer to
a new machine your license will no longer work and you should retrieve your license using the
Retrieve license On-line button: you will need your original OrderID.
The license Data shows the Name, Company, and Email address of the license buyer. It also shows
the date of issue of the license, a license ID and the Status of the license.
The license Status can be one of three states:


OK - the license is good.



Evaluation - No license has been obtained and VisNetic MailServer is in its 30-day evaluation
period.



Reference key mismatch - this occurs when the license is being used on a machine that it was
not registered for.

If you have a license file then you should press the Browse for license file button, locate and select
the license file, and press Register.
If you have a license block then you should cut and paste it into the license window and press
Register.

Status Bar
The Status Bar at the bottom shows three pieces of information.
The leftmost shows you whether you are connected to a remote or local server (local in the above
screenshot). Additionally, if you are connected to a remote server, the version of VisNetic MailServer
is shown.
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The middle shows which Menu node you have selected at present (Management in the above
screenshot).
The rightmost shows you which interface mode you are using (advanced in the above screenshot).
The interface mode governs which options are available within the VisNetic MailServer Console. You
can change the mode in Options -> Interface Mode.

Languages
VisNetic MailServer is in English by default but it can be localized to other languages by loading a
language xml file.
Various language files are available but you can also write your own if you wish.
The language file to be used at startup can be specified in file info.xml or you can switch between
languages using the Options -> Languages menu item. It will expand to show all available language
files. Select one and the interface will immediately start to use that language.

The language XML files have to be located in the folder ..<InstallDirectory>/xml/lang and each XML
file should have a language identification tag as the first line.
For example: the Portuguese language file should be called lang_pt.xml and should look something
like this:
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<?lang caption="Portugese" abbr="PT" translator="Pele" contact="pele@somedomain.br"
langversion="1.5" merakversion="8.2.2" date="2005-07-20"?>
<?xml version="1.0" encoding="UTF-8"?>
<APPLICATION><FORMS><FORM ID='TConfigForm' CAPTION='Administraçăo do VisNetic
MailServer'><ITEM ID='AccountsSheet' CLASS='ttabsheet' CAPTION='Contas'/>
<ITEM ID='AccountsDomainSheet' CLASS='ttabsheet' CAPTION='Contas de domínios'/>
<ITEM ID='UserGroupsSheet' CLASS='ttabsheet' CAPTION='Grupos de Usuários'/>
<ITEM ID='AccountGlobalSheet' CLASS='ttabsheet' CAPTION='Configuraçőes Globais'/>
<ITEM ID='AccountDefaultsSheet' CLASS='ttabsheet' CAPTION='Contas'/>
<ITEM ID='AccountDefaultsGroupBox' CLASS='tgroupbox' CAPTION='Padrőes de contas'/>
....

NOTE that if you revert to the 'Default' language (English) you must also restart the Console. This is
because there is no English language xml file, it is part of the core program.
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Command Line Tool
There is a completely new command line tool which you can use not only to administer domains and
accounts but also all system variables. This tool is called tool.exe and you can find it directly in the
<InstallDirectory> folder. It is easy to use and you only have to know the API constants. Complete
list of API constants is in APIconst.pas file in <InstallDirectory>\API\Delphi\ folder.
Please note, that using tool.exe for performing large operation can cause temporary service
unavailability. This is because for some change in configuration, the service need sometimes
restarted. For servers with many domains and many users with high load, this restart can take a
while. We recommend to do so in time period (for example night) when the load is lowest.

Command

Description

CREATE

Creates a new object. It is followed by a type (domain or account) and a list of
variables and values you want to assign to these variables.

DELETE

Deletes an object. It is followed by a type (domain or account) and a unique
name of object you want to delete.

MODIFY

Modifies any variable (property) of an object. It is followed by a type of object
and a list of variables and values you want to assign to these variables.

DISPLAY

Displays any variable (property) of an object. It is followed by a type of object
(domain, account or system) and a list of variables you want to show.

EXPORT

Does the same as DISPLAY command but this command shows on the screen
everything separated by comma. (CSV format)

FILE

Calls file functions. It is followed by USERSTATISTICS and all its parameters
(see below).

Parameter

Description

ACCOUNT
[variables]

Address any account on the server.

DOMAIN [variables]

Address any domain on the server.

SYSTEM [variables]

Address any system variable such as c_version, c_name, etc. List is also in
APIConst.pas

20

Reference Manual VisNetic MailServer

BATCH batchfile

Allows you to run a batch file with a set of commands included. See examples
below.
Batchfile is just a common text file with commands. Each on a separate line.
These commands must not include "tool" at the beginning. Just the commands
and parameters.

USERSTATISTICS
fromdate todate
filterstring
outputfile

Saves userstatistics between fromdate and todate to specified output file for all
users that fulfill the condition of filterstring.
fromdate,todate have yyyy/mm/dd format
filterstring supports also asterisks and question marks to specify more
accounts. If it does not contain @ symbol it is considered as domain name.
outputfile If you do not specify absolute path, it will be saved to
<InstallDirectory> folder.

How to create other types of accounts
To do this, you have to use u_type property. Its values are also written in APIConst.pas file. For
example mailing list has 1 as a value of this property. So if I want to create mailing list I will have to
use this:
tool create account mailing@vmsdemo.com u_type 1 m_owneraddress "admin@vmsdemo.com"

Usage
tool create account new@vmsdemo.com u_name "New Account" u_password "pass"
u_accounttype 2


It creates an account with New Account in Full Name field and pass as password.
tool display account new@vmsdemo.com u_mailbox u_accounttype



It shows you values of both variables u_mailbox and u_accounttype of new@vmsdemo.com
account.
tool delete domain oldone.net



It deletes oldone.net domain from your server.
tool modify account *@vmsdemo.com u_accounttype 2



It changes all accounts in vmsdemo.com to IMAP accounts.
tool file userstatistics 2004/12/25 2004/12/31 vmsdemo.com statistics.txt



It saves userstatistics between dates 2004/12/25 and 2004/12/31 for all accounts in
vmsdemo.com domain to statistics.txt file. This file can be found in <InstallDirectory> folder.
tool export domain * d_description d_postmaster



It shows on the screen d_description and d_postmaster variables for all domains in CSV format each value is separated by comma.
tool export account *@* u_mailbox u_name u_password > accounts.txt
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besides exporting the 3 above fields it also puts user's full email address in first column
tool import account contas.txt u_mailbox u_name u_password



import the 3 fields from CSV
tool display system c_config_services_pop3_port



It shows the system variable that contains a POP3 service port.
tool file batch create_mailing.txt



where create_mailing.txt looks like:
create account mailing1@vmsdemo.com u_type 1 m_owneraddress "admin@vmsdemo.com"
create account mailing2@vmsdemo.com u_type 1 m_owneraddress "admin@vmsdemo.com"
create account mailing3@vmsdemo.com u_type 1 m_owneraddress "admin@vmsdemo.com"



It creates three mailing lists defined in create_mailing.txt file.
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CHAPTER 4

WebAdmin
A part of VisNetic MailServer version 8.3 is also a brand new WebAdmin. The old one is not there
anymore. It can fully substitute VisNetic MailServer Console and its Remote Server
Administration (on page 6). The new WebAdmin allows you to administer all settings (including
domains and accounts, AntiSpam, AntiVirus, groupware, ...) on your server.
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Its usage is very easy because the design of the options is very similar to the one you know from
VisNetic MailServer Console. There is context sensitive help available for all screen in webadmin,
simply click the blue (?) button located in right top corner.

You can access new WebAdmin at
http://yourIP[:ControlServicePort]/admin/
or
http://hostname[:ControlServicePort]/admin/
Example:

24
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If you are running Control Service on the default port 32000 and you have your server installed on a
computer with IP address 83.21.14.51 you can access WebAdmin at
http://83.21.14.51:32000/admin/

Additionally, you can set a new web service on your VisNetic MailServer to remove accounts from
the URL and access WebAdmin at some nicer URL. e.g. http://webadmin.yourdomain.com.
A great feature of new WebAdmin is that you can exactly specify who can edit/see which options in
WebAdmin. You have to do that in Domain Admin Rights -> Advanced.
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Shared
This chapter contains only parts of documentation which would have to be used on more places. So
there are links to appropriate sections instead and such sections are stored in this chapter to
decrease the greater size which could be caused by reusing them on more places.
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Schedule ................................................................ 31
Domain Admin Rights............................................... 32
Select Accounts....................................................... 33
Account Options ...................................................... 34

Simple RegEx Tutorial
Regular Expression can be used in Content Filter conditions.
Regular Expressions can be extremely complex but they are very flexible and powerful and can be
used to perform comparisons that cannot be done using the other checks available.
There follows some very basic examples of regular expression usage. For a complete description
please visit www.regular-expressions.info (http://www.regular-expressions.info).

^' and '$'
First of all, let's take a look at two special symbols: '^' and '$'. These symbols indicate the start and
the end of a string, respectively:
"^The"

matches any string that starts with "The".

"of
despair$"

matches a string that ends in with "of despair".

"^abc$"

a string that starts and ends with "abc" - effectively an exact match
comparison.

"notice"

a string that has the text "notice" in it.

You can see that if you don't use either of these two characters, you're saying that the pattern may
occur anywhere inside the string -- you're not "hooking" it to any of the edges.
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'*', '+', and '?'
In addition, the symbols '*', '+', and '?', denote the number of times a character or a sequence of
characters may occur. What they mean is: "zero or more", "one or more", and "zero or one." Here
are some examples:
"ab*"

matches a string that has an a followed by zero or more b's ("ac", "abc",
"abbc", etc.)

"ab+"

same, but there's at least one b ("abc", "abbc", etc., but not "ac")

"ab?"

there might be a single b or not ("ac", "abc" but not "abbc").

"a?b+$"

a possible 'a' followed by one or more 'b's at the end of the string:
Matches any string ending with "ab", "abb", "abbb" etc. or "b", "bb" etc. but
not "aab", "aabb" etc.

Braces { }
You can also use bounds, which appear inside braces and indicate ranges in the number of
occurrences:
"ab{2}"

matches a string that has an a followed by exactly two b's ("abb")

"ab{2,}"

there are at least two b's ("abb", "abbbb", etc.)

"ab{3,5}"

from three to five b's ("abbb", "abbbb", or "abbbbb")

Note that you must always specify the first number of a range (i.e., "{0,2}", not "{,2}"). Also, as
you might have noticed, the symbols '*', '+', and '?' have the same effect as using the bounds
"{0,}", "{1,}", and "{0,1}", respectively.
Now, to quantify a sequence of characters, put them inside parentheses:
"a(bc)*"

matches a string that has an a followed by zero or more copies of the
sequence "bc"

"a(bc){1,5}
"

one through five copies of "bc."

'|' OR operator
There's also the '|' symbol, which works as an OR operator:
"hi|hello"

matches a string that has either "hi" or "hello" in it

"(b|cd)ef"

a string that has either "bef" or "cdef"

"(a|b)*c"

a string that has a sequence of alternating a's and b's ending in a c
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('.')
A period ('.') stands for any single character:
"a.[0-9]"

matches a string that has an a followed by one character and a digit

"^.{3}$"

a string with exactly 3 characters

Bracket expressions
specify which characters are allowed in a single position of a string:
"[ab]"

matches a string that has either an a or a b (that's the same as "a|b")

"[a-d]"

a string that has lowercase letters 'a' through 'd' (that's equal to "a|b|c|d" and
even "[abcd]")

"^[a-zA-Z]"

a string that starts with a letter

"[0-9]%"

a string that has a single digit before a percent sign

",[a-zA-Z09]$"

a string that ends in a comma followed by an alphanumeric character

You can also list which characters you DON'T want -- just use a '^' as the first symbol in a bracket
expression (i.e., "%[^a- zA-Z]%" matches a string with a character that is not a letter between two
percent signs).
In order to be taken literally, you must escape the characters "^.[$()|*+?{\" with a backslash ('\'),
as they have special meaning. On top of that, you must escape the backslash character itself in
PHP3 strings, so, for instance, the regular expression "(\$|A)[0-9]+" would have the function call:
ereg("(\\$|A)[0-9]+", $str) (what string does that validate?)
Just don't forget that bracket expressions are an exception to that rule--inside them, all special
characters, including the backslash ('\'), lose their special powers (i.e., "[*\+?{}.]" matches exactly
any of the characters inside the brackets). And, as the regex manual pages tell us: "To include a
literal ']' in the list, make it the first character (following a possible '^'). To include a literal '-', make
it the first or last character, or the second endpoint of a range."

28

Reference Manual VisNetic MailServer

Database Settings

ODBC settings dialog lets you specify the ODBC source, connection details, create and drop tables
and perform a connection test.
Field

Description

Primary connection

This field specifies the complete connection string to the ODBC source. It contains the
DSN, Server, username and password.

Backup connection

The backup connection string serves as a backup solution if the primary connection
cannot be used. It has the same format as the Primary connection.

Database Syntax

Choose the database type that corresponds to your database from the drop-down list.
The default option is MS Access, which is included with VisNetic MailServer.
Other supported database types are:
MS SQL
MySQL
Interbase
Oracle
Firebird
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SQLite, also included with VisNetic MailServer

Database Driver

Choose the DB driver that corresponds to your database.
The default option is ODBC, which will work with all databases except for:
MySQL - select MySQL
SQLite - select SQLite
Firebird - select Firebird

Buttons
Field

Description

Create Tables

This button creates the required tables in the ODBC source. You have to create the
right tables for every ODBC source.

Drop Tables

The created tables will be deleted from the ODBC source using this button.

Test Connection

Always perform the ODBC connection tests. If the test is successful you setup all the
information properly. If not you have to make changes.

Step by step:
1

Create a System DSN in the Control Panel - Administrator Settings - ODBC Data Sources to
connect to your DB. Make sure it is a System DSN and not a User DSN.

2

Fill in the proper connection string. Specify a backup connection if required. Test with
the Test Connection button.

3

Create the tables using the Create Tables button.

4

Press the OK button.
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Access Mode

The access mode lets you specify the behavior of the particular feature based on the given details.
By default the feature is applied to all users and domains. This can be changed to suite your
requirements.

Field

Description

All accounts

This mode specifies that the feature should be applied to all accounts and
domains on the server. This is the default mode.

Accounts from list

Let you specify accounts, groups or domains using the '...' button through simple
and clear Select Accounts Dialog (see "Select Accounts" on page 33). See the
exemplar sceenshot above for this scenario.

Selected domains

Only the accounts in the selected domains will be applied the feature.
See the domain services access.

Selected accounts

Only the selected accounts will be applied this feature.
See the user services access.

All except selected
domains and
accounts

All accounts on all domains will be applied the feature if disabled on both the
domain and user. If both the domain and user are enabled the feature will be
applied. If either domain or user is enabled it will not be applied.

(Logical NOT XOR)

user - enabled domain - enabled -> service enabled for particular user
user - enabled domain - disabled -> service disabled for particular user
user - disabled domain - enabled -> service disabled for particular user
user - disabled domain - disabled -> service enabled for particular user
See the domain and user services access.
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Schedule

You can determine when these rules should be processed. You can choose to have them processed
once a day, or you can completely disable them.

At each rule, you can choose the days in the week when it should be processed and you can choose
Once At to do it only once a day, Every and set the period to be repeated in and a time period of
day when it should be processed or you can disable this item completely.
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Domain Admin Rights

Here you can define the rights for Domain Administrators. The options are self-explanatory. By
default, you can assign the rights to manage particular type of accounts. If you check it only in the
dialog, it means Domain Administrator will have rights to manage such accounts only in the domain
it belongs to. If you want to assign Domain Administrator also rights for different domains, you have
to use domain.dat file - click Advanced button to edit the file.
In that file, you can assign rights not only for type of accounts and additional domains but you can
also exactly define which domain options can the domain administrator edit/change/see. See the
example file for exact syntax.
The rights that are assigned by default are to access User, Mailing list and List server accounts. This
domain administrator is also prevented from accessing users mailboxes and read their messages.
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Select Accounts

This dialogue allows you to pick accounts, domains or groups for the certain object container.
Wherever any account, domain or group requires selection, it is done through this straight forward
and simple select dialogue.

Field

Description

Domain + Select
Domain

Use the combo and the button to choose any domain locally hosted. In the
middle pane, the list of accounts is displayed.

Account type

Combo that is allowing you to pre-filter the accounts or groups in the selected
domain.

Select Account

Once you selected the account you want to add to container (group, mailing list,
remote watchdog, quarantine, ...) click this button to confirm the selection.

Hitting "Cancel", cancels the current selection process and returns to the previous screen.
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Account Options

You can use this dialogue to define values in both Accounts Defaults and User Groups. The
difference between those two dialogs is that User Groups apply the settings to already created users
but Account Defaults is applied to newly created accounts. The option names are the same as
options in User properties tabs or Domain properties tabs respectively.
Account Defaults can be set at two difference places:


the global one - here you can set also default values for domain creation



the domain one - here you can set only user options
If particular domain does not have any Account Defaults set, the global one will be used.
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