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CHAPTER 1

About this document
This document is intended to help first-time VisNetic MailServer users to get familiar with the
VisNetic MailServer administration interface and basic features, using the hands-on method of an
initial software setup.
It will also showcase the extra benefits of using VisNetic MailServer over other, similar, products.
This document refers to VisNetic MailServer for Windows.
Latest revision of manuals is available on our website:
http:// www.Deerfield.com/products/VisNetic-MailServer
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VisNetic MailServer Overview
VisNetic MailServer is a premium mail server software.
It is extremely robust, fully-featured, and easy to use.
Since it first hit the market over 6 years ago, it has evolved into a comprehensive messaging
platform for electronic communication, covering:


secure e-mail service with integrated antivirus and antispam



webmail access



groupware with Outlook plug-in



instant messaging



VoIP server
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web server



FTP



SyncML



and many others

Couple these features with:
• high-performance, resource aware, and easily scalable engine
• flexibility of settings
• field-proven compatibility
• extensible features for system integration
and VisNetic MailServer is easily the best choice for a wide range of environments - offices and
schools, corporations and industries, right up to the most demanding installations at ISPs and
service hosting providers.

VisNetic MailServer Highlights
VisNetic MailServer offers an unparalleled set of features, designed to meet the requirements of all
deployment scenarios:
•

SMTP / POP3 / IMAPv4 / HTTP / LDAP / Jabber / Proxy / SNMP and SIP protocols with
SSL/TLS encryption

•

IPv6 ready

•

Advanced security through extensive password, protocol and usage policies, intrusion
prevention and certificate management

•

SyncML, WebDAV, CalDAV, vCal, vCard, vFreeBusy compatible

•

Clustering, load-balancing, distributed services

•

ODBC database storage for accounts, logs, and operational data

•

Service and system monitoring, detailed logging, log rotation, syslog server support,
traffic statistics and charts

•

Multi-threaded engines, multi-CPU system support, file system optimizations, enhanced
memory architecture, DNS caching

•

Zero downtime server migration and database migration tools

•

Integrated archive and backup tools, task scheduler, tunneling frontend

VisNetic MailServer licensing is flexible enough to meet every budget and user base and keep up
with your needs as you grow.
Starting from 12 user accounts with unlimited domains and 1 year of upgrades, the license can be
upgraded at any time to allow more accounts.

About this document

It can be used as a High performance spam and virus filtering gateway for MS Exchange or other
mail server, enhancing the reliability and security of the service.
Or you can migrate directly from your existing solution using the zero downtime Migration Tool.
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Requirements
In This Chapter
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Networking ............................................................ 5

Hardware
VisNetic MailServer can run well on fairly modest hardware.
For a basic service (a few hundred user accounts) a Pentium class processor and 1GB RAM will
suffice.
If you plan to have thousands of users, or expect heavy traffic, you should consider a multi-CPU
system with Xenon processor or better, at least 2GB RAM, and a fast disk sub-system (SerialATA,
SCSI).
RAID is beneficial only if you require top data integrity or if configured to maximize disk I/O speed.
An external fileserver for data storage and backup is recommended for ISP-class installations.

Software
VisNetic MailServer installer is almost everything you need.
VisNetic MailServer runs on any server or desktop Windows OS.
However, WebMail will not work on the integrated webserver under NT4 server as the required
version of PHP is not available for NT4.
An external SQL database can be used as central storage, and is recommended for larger
installations. VisNetic MailServer uses ODBC for connection so any compliant database can be used,
e.g.
•

MS SQL 2000, 2003

•

MySql

•

sqlite

•

Oracle

•

PostgreSql.
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MS Access is used as the default database storage, so make sure it is installed within the system (
supplied as a default with MS Windows).
PHP libraries are distributed along with the integrated Web Server and won't interfere with any other
installation on the same computer.

Networking
LAN installation requires a working Ethernet connection with assigned static IP address and/or
hostname.
WAN installation requires either a dial-up or permanent connection to the internet, a public (WAN)
IP address and a hostname.
Your (or your ISP's) DNS server IP address is required for direct delivery of e-mail to Internet
locations.
You need to set your ISP's or company network DNS server's authoritative (A) and mail-exchange
(MX) records to point to your server. Ask your connection provider to do this for you. The records
may take up to 24 hours (or even 3 days) to propagate over the Internet, so ensure this in advance.
The records look like this:
"mail server hostname" A "mail server IP address", e.g. mail.yourdomain.com A 193.179.128.218
"domain name" MX "mail server hostname" "priority number", e.g. yourdomain.com MX
mail.yournewdomain.com 10
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Installation Process
Installing VisNetic MailServer is a matter of running the vmssetup_en.exe.
The Installation wizard will ask you only if interaction is necessary.
If you are upgrading, it will stop and start services automatically to maximize availability.
For a complete walk-through of the installation procedure, please read the VisNetic MailServer
Installation Guide.

In This Chapter
Download ............................................................... 6
Run Installation Wizard ............................................ 6

Download
The latest version is always available for download on our website.
http://www.deerfield.com/products/visnetic-mailserver/
The executable includes the installer, Release Notes and License Agreement.

Run Installation Wizard
Double-click vmsetup_en.exe to start the installation wizard.
If you install VisNetic MailServer for the first time, you will be asked for registration details.
Choose the drive and folder where the software will be installed. This will be the VisNetic MailServer
root folder. It is recommended that this folder is on your primary drive (usually C:). It does not
have to reside under "Program Files", and you can also shorten the folder name, which can help
save keystrokes in larger installations where the Command Line Tool may be used more often.
If you are re-installing or upgrading, you should be sure to point to the same directory as your
previous installation, otherwise you may lose valuable information.
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Administration interfaces
The VisNetic MailServer Interface (AKA Console, Administration Console, GUI) will be your primary
way of making changes and adding accounts to VisNetic MailServer, at least in the short term.
The Interface has been carefully designed to be intuitive and you will soon become comfortable with
its layout and usage.
This section introduces the Interface.

In This Chapter
Overview ............................................................... 7
Saving changes ....................................................... 9
Languages.............................................................. 9
Help ...................................................................... 9

Overview
Most of the time you will use the VisNetic MailServer Console to manage your server.
Start - VisNetic MailServer - VisNetic MailServer Administration (config.exe in <InstallDirectory>
root directory).
This runs locally on the server and its use is required for administration of certain features
(ODBC, filesystem related, properties of Control service).
There are a couple of other ways to update VisNetic MailServer


The Remote Administration Console (available from our website). Allows you to manage the
server remotely.
Download the package.
Unpack the contents to any folder on your workstation.
When started, it will ask for connection and login details, then you will be able to work as if
sitting by the server.
However, you will need to use some kind of remote access to the server (Terminal Services,
pcAnywhere, VNC) and run the administration console locally when you need to set options
that are grayed out.
TIP: You can run multiple instances of config.exe allowing you to compare settings on
different machines.



The WebAdmin interface
A web-based, installation-free interface for server management from any Internet-connected
computer.
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Provides the same options as the Remote Administration Console application.
Initially, login is only possible with a system administrator account, but you can also grant
access to it for domain administrators, along with defined access rights.
Use a standard web browser to access http://yourserver:32000/admin


An advanced command line tool, called Tool.exe.
This is found in <InstallDirectory>\tool.exe.
It is usually used to read or modify settings of a large set of objects, using VisNetic
MailServer's API to directly access the mail server engine, e.g. to list what users have certain
options set.
Run it without parameters for syntax and examples.

The Console Menu Bar.
The File menu
•

Contains commands related to saving and restoring configuration, you can also open any
file and connect to or disconnect a remote server.

The Options menu
•

Includes settings specific to the administration console with self-explanatory meaning.
Here you can lock the console to be accessible only with administrator's login and
password.

The Accounts menu
•

Lets you manage accounts and domains, or show information related to a selected
account. The same menu appears when you right-click user or domain listed under
Management node.

The Help menu
•

Is where to go for additional information about the software.

•

The first few items open links to places of interest on our website.

•

The option Check for current version on the Internet does just this and lets you start the
download immediately.

•

Next section opens Help topics, then there are shortcuts to current version's Release
Notes and License Agreement. Licenses lets you review and activate your license.

•

About will tell you which version you are running.

Console Toolbar Customization
The Console Toolbar can be customized to suit your working method.
Use Options - Customize Toolbar to shape it as you like.
An intuitive dialog opens allowing you to add icons and "dividers" to your custom toolbar.

Chapter 4
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Saving changes
You should be aware that Settings are not saved "only the fly" while you are using the Console - this
is to prevent accidental modification which could cause serious problems.
To save Settings at any time just press the Save button above the settings pane of the console.
NOTE - that if you switch to a different tab you will be prompted to save any changes you have
made. This also happens if you close the console while changes are pending.

Languages
The administration interface is in English by default, but localization to national languages can be
provided by your reseller.
A language specific, XML formatted, file is placed in the <InstallDirectory>\xml\lang directory, and
this language will become available under the Options->Languages menu item.

Help
Press F1 anytime you are unsure or curious about what the particular option does and contextsensitive help will open just on the right page.
For further help:


Printable documentation, in PDF format, is available on our website.



On-line version of the manual may be useful.



Frequently asked questions are continuously updated.



Share experience with others in user forum.



Knowledge base access free of charge for registered users is coming soon.
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Getting your VisNetic MailServer
online
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Firewall and routers
VisNetic MailServer should be located behind a hardware or at least software firewall.
The table below lists the default ports that need to be open for particular services.
These are default port numbers, you can change them in System - Services, in a dialog which
opens by double-clicking the service or selecting the service from the list and clicking Properties..
button.
Port to be
Opened

Protocol

Direction

Module(s)

25

SMTP

in/out

Mail Server

21

FTP

in/out

FTP Server

32000

Instant Messaging Server

80

HTTP

out

Web Server

110

POP3

in/out

Mail Server

143

IMAP

in/out

Mail Server

465

SMTP (SSL)

Mail Server
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990

FTP (SSL)

in/out

FTP Server

993

IMAP (SSL)

in/out

Mail Server

995

POP3 (SSL)

in/out

Mail Server

5222

Jabber

in/out

Instant Messaging Server

5223

Jabber (SSL)

in/out

Instant Messaging Server

5229

GroupWare

in/out

GroupWare Server

32000

HTTP

WebMail, Mail Server

32001

HTTP (SSL)

WebMail, Web Server

Ensure that your server is reachable from the outside world. If it has a static IP address, this must
be allowed on firewall.
Ping it from another computer
Try tracert if ping is disabled by network settings.
Try accessing www.whatsmyip.com http://www.whatsmyip.com from the server. Your IP
address is displayed.
<Recommendations on network security>

Dial-up Access
VisNetic MailServer can run via dial-up access, although you should not do this if VisNetic MailServer
is to be a fully-featured Email Server. VisNetic MailServer needs to be contactable by any mail
server that wants to send to your domain, and should therefore be permanently connected to the
internet.
Having said that, however, VisNetic MailServer can be used as an email collector only and for this
purpose a dial-up connection may suffice.
If you have dial-up access, you should already have your Internet Connection defined in Windows,
and you now need to tell VisNetic MailServer
From the VisNetic MailServer Console:


Navigate to System - Internet Connection.



Choose the Dial-up connection radio button
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Click the Dial-up Settings button.



Select your connection from the drop-down list.



Enter your login and password details, and any connection options required by your Service
Provider.



Click Apply.



Click Connect Now if you wish VisNetic MailServer to connect immediately.

NOTE - you can also set up a Global schedule for connecting to the internet, and individual
schedules for Domains. See the documentation for more information.

Check your DNS Records
To check that your DNS "A" and "MX" records are correctly setup run the DNS Query Tool supplied
with VisNetic MailServer
Start -> Program Files ->Deerfield.com -> VisNetic MailServer -> DNS Query Tool
And use the following to sets of settings to verify your records:

"A" record test
The DNS "A" record (or Address Record) maps your domain name to your IP Address.
Query: mail.yourserver.com
Type: Host address (A)
DNS: your DNS server's IP address
DNS Timeout: 5 seconds
Click Lookup.
The IP address of your VisNetic MailServer should be displayed.

"MX" record test
The DNS "MX" record (or Mail Exchange Record) tells Mail Clients the hostname they should connect
to to deliver mail:
Query: yourserver.com
Type: Mail exchange (MX)
DNS: your DNS server's IP address
DNS Timeout: 5 seconds
Click Lookup.
Your VisNetic MailServer hostname should appear in the list.

Chapter 5
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Problems with DNS
Problems are mostly caused by a firewall or router blocking the connection, or your DNS server not
being reachable or configured incorrectly. The following steps may help you diagnose the problem


Review your settings, contact your ISP or network administrator and try again.



In the Administration Console, choose System - Connection, and
1. Check that the DNS Server field lists the DNS Server IP address you used to test the
connection earlier.
2. You can enter additional DNS Server IP addresses, delimited with a semicolon.
3. Click the Test DNS button to test the functionality of the servers you specified.

Setup the SMTP service
The SMTP Service is the Service that sends emails to other email servers on the Internet
In the VisNetic MailServer Console, choose Mail Service - SMTP Service.


Select the General tab



Enter Your VisNetic MailServer's hostname with the correct value.



Select Use DNS lookup for direct delivery of outbound messages.



Check the Use relay server option only if you want to send messages using your ISPs (or
another) mail server to send messages.
Enter authentication details to the server with the following syntax:
username%domain.com:password@ISPhostname.



In System - Service, check that SMTP service is running.
If not, select the service from the list and click Start button in the bottom, or right-click the
service and choose Start from the context menu.
If it doesn't start, it may be conflicting with another service running on its default port 25,
typically Microsoft Messaging Server.
Stop the service that's blocking the port.

Basic Security recommendations
Above and beyond the standard network security for your Online Server, you should also check that
your server is not open to abuse from Spammers.
The following options should be checked:


Closed Relay - in Security Node - General tab
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POP before SMTP - in Security Node - General tab

Advanced Security Recommendations
Security - DNS tab
Use DNSBL (DNS blackhole list):
sbl-xbl.spamhaus.org (combined list)
bl.spamcop.org
dul.dhsbl.sorbs.net (dial-up list)
Reject if originator's IP has no rDNS
Reject if originator's domain does not exist (has no A record)

Security - Intrusion Prevention tab
Check Active
Block IP addresses that...
•

Gets denied for relaying

•

Establishes number of connections in 1 minute: 6

•

Exceeds RSET session count: 5

•

Gets listed on DNSBL

•

Amount of time for IP address to be blocked (Min): 30

•

Close blocked connections

Server Diagnostics
In the System -> Services Node there is a Server Diagnostics button which will perform a series of
tests and report the results.
Click Server Diagnostics, the following tests are performed:


DNS server availability and address resolution.



Primary domain MX record is configured properly.



Internet connectivity test



Internet (SMTP, POP3 and Control) services running.



SMTP message transfer, by sending a test message to itself.

Chapter 5

All tests should be successful.
Any failing test should be investigated.
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CHAPTER 6

Create new Domain
VisNetic MailServer is capable of supporting multiple domains, to create a new one, use the
following procedure:


Select Accounts -> New Domain from the Main menu.



Enter the new Domain name.



Enter a short description.



Select Type > Standard.



Specify an e-mail address for the Domain Administrator account, which will be used by the
system for notification emails and system reports.



Press Save

Your new domain is now created and ready for use. See the "Domains and Accounts Reference"
manual for more information.

In This Chapter
The Primary Domain ................................................ 16

The Primary Domain
VisNetic MailServer supports multiple domains, but one of them must be set to be the Primary
Domain, all the other are Secondary domains.
Functionally, there is no difference between a Primary and a Secondary Domain, but the Primary
Domain Administrator Email address is used for sending any system notifications or reports.
With the default installation, the demo domain is the Primary Domain, but this is easily changed by:
Select Domains & Accounts - Management node.
Select the Domain you want to make Primary.
Select Account -> Make Primary
or
Right Click and select Make Primary.
You have now set your Primary Domain.

Chapter 6
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TIPS
Your primary Account Administrator email address is used by VisNetic MailServer to send system
notifications or reports. It is recommended that a second address is specified, that is remote from
this VisNetic MailServer, so problem reports can be received externally.
The Primary domain is always listed first in Management pane, other domains are then listed
alphabetically.
Mail sent to a user created in primary domain doesn't have to include the domain name part of email address.

18

CHAPTER 7

Dial-up access to ISPs mailboxes
If you want to collect all e-mail addressed to your domain name from a ‘catch-all’ POP3 account at
your ISP, you will need to setup one extra domain of Type: ETRN/ATRN.
In the Value field of the Domain, enter the IP address of your server if it's static, or leave it blank for
a dynamic IP.
Create one user account in this domain to allow the collecting server to log in.
The Username and password must match the login username and password for your ISP's POP3
account.
Under this user's properties, switch to Options tab and check the ETRN/ATRN Account option.
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CHAPTER 8

Create an Administrator account
There are three types of User Account - Administrator, Domain Administrator, and Standard User.
Administrator Accounts have access to modify all server settings for all Domains within your
VisNetic MailServer System. They can create, modify and delete Domains and Accounts. They
can create further Administrator accounts. Administrator Accounts are assigned a red icon in
the accounts list for easy identification.
Domain Administrator Accounts (with blue icons) can modify server settings for the Domain
they belong to. A Domain administrator for one domain can also be set as a domain
administrator for another domain.
Standard Users have black icons and only have access to some of their own account settings.
To setup your Administrator Account.


In the Administration Console, select the Domains & Accounts -> Management Node.



Select the Domain you wish to add the Account to.



Select Accounts -> Add -> User from the Main Menu. The settings pane will reset to default
settings.



Enter one or more aliases, separated by semi-colons. Be aware that some default
administrator aliases are created for the domain when you define it, you do not need to
repeat these here, but one alias is required here.



Fill in all other details as necessary (press F1 for context sensitive help at any time).



Select Administrator from the drop down menu



Click Save, and your Administrator Account is set up.



Finally, select the Domain and make sure that the new Administrator address is set in the
Administrator Email field.

In This Chapter
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CHAPTER 9
Create new user account
Creating a new User Account is the same process as described in Create an Administrator
account (on page 19), except that you choose Standard from the Permissions drop-down box.
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Setup email client
Follow these guidelines to set up an email client (MS Outlook, Eudora, Pegasus, etc.).


Outgoing Server - Your VisNetic MailServer Hostname.



Incoming Server - your VisNetic MailServer Hostname.



User Name - the User Account Username. Note that you can set VisNetic MailServer to require
the full email address as the User Name.



Server Type - select POP3 or IMAP as you prefer. POP3 downloads messages to your client for
reading whereas IMAP requires a direct connection to the server.



Be aware that this setting should match the Account Type(s) you chose for the User.



SMTP Authentication - if you have set your VisNetic MailServer to require SMTP Authentication
then you need to tell your client this, and the username and password to log in with (same as
for POP3).
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CHAPTER 11

What's Next
Further information on VisNetic MailServer can be found within the comprehensive documentation
set, downloadable from our Website. Each VisNetic MailServer Node has its own dedicated manual
so you can just get to the information you require
You can also get help by pressing F1 at any time while the console is open. This opens a contextsensitive help file containing:


All the "node" manuals combined.



Introductory topics.



Common problems/mistakes.



How To guides



Tips for deployment
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Checklist
Here is a checklist you can use to ensure that basic settings are correct:


Review TCP/IP settings
Ping your mail server. If you get any packet loss, the problem may lie within your network.



Telnet your server at port 25.
You need to have telnet access enabled for this test. If you are able to ping but not telnet, the
problem may be with your firewall.



Review client settings



Check firewall settings



Check DNS resolution
Ping your DNS servers from your mail server (do you get any packet loss)?
DNS server response time is crucial for processing heavy e-mail traffic. and maybe choose a
different server or add another one to the list in case the first one timed out.
Use the supplied tool dnsquery.exe to test it as described earlier.
Try using another DNS server, just Google for "public DNS server".



Check server diagnostics
node Services - Server Diagnostics button



Check licensing
menu Help - Licenses



Check logs
Status - Logs, look in Error log, SMTP log, Web/Control log, POP3 log



Restart services



Restart the server



Disable additional features that might be incorrectly configured, one by one to attempt to
isolate a cause.



Uncheck Active in these tabs:
Filters - Content Filters
Security - Intrusion Prevention
Anti-Spam - Greylisting.



Check disk
Use chkdsk c: /f to check your disk for possible bad sectors and repair them.



And, if you are really stuck - Submit a support request:
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Please supply as much detail as possible - which version are you running, whether it is a new
install or an upgrade, which points from this checklist showed something unusual, under what
circumstances does the error appear, when it started to exhibit, how to reproduce the
problem. Anything that may be useful to our technicians in resolving your problem.
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